
WordService 

Thank you for using our freeware. This service provides a number of functions to convert or 

format the currently selected text, insert data or show statistics of the selection within all Co-

coa applications, e.g. TextEdit, Mail, Stickies, DEVONthink, supporting services. 

System requirements 

Mac with Intel processor, OS X 10.6.8 or later. 

Installing and updating 

Simply move WordService into your Applications or Applications/Utilities folder or into the folder 

Services (in the Finder visit the Go menu with the Option key pressed; choose Library; locate a 

folder named Services; if there is none, you can safely create it manually). Double-clicking ser-

vice let’s OS X learn about its new abilities; alternatively log out and in again. 

In addition you may need to switch on the new Services menu options. Open System Preferences, 

then navigate to Keyboard > Keyboard Shortcuts > Services > Text. Turn on all options you want 

and optionally add a keyboard shortcut. 

Using the WordService services 

Select a text and choose the desired menu item in the Services menu (or press the appropriate 

shortcut if available). To remove unnecessary entries from your Services menu, use the Services 

Preferences option from the Services menu. 

Note: The default tabulator width is set to 4. If you want to change this value, modify the file 

‘org.grunenberg.wordservice.plist’ in your Preferences folder using PropertyListEditor, PrefEdit, 
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or any text editor, e.g. TextEdit. Alternatively use the following command in Terminal (replace 

“8” with the desired width): defaults write org.grunenberg.wordservice TabulatorWidth 8 

Functions 

Insert 

• Contents Of Path  Insert files and folders of the selected path (tilde is                                               

expanded) and of all its subdirectories (e.g. select the 

path ‘~/’ and this function will insert all contents of 

your home directory). 

• Short Date  Insert the current date in short form.                                                             

• Long Date  Insert the current date in long form.                                                               

• Short Date & Time  Insert the current date and time in short form.                                            

• Long Date & Time  Insert the current date and time in long form.                                              

• Time  Insert the current time.                                                                           

!
The date and time commands don’t need selected text. They use the default system language 

and date and time formats. 

Convert 

• Initial Caps Of Sentences  Makes the first letter of every sentence uppercase.                              

• Initial Caps Of Words  Makes the first letter of every word uppercase.                                      

• Lowercase  Makes all letters lowercase.                                                              

• All Caps  Makes all letters uppercase.                                                                    

• Decode Tabs  Convert tabs to spaces.                                                         

• Encode Tab  Convert spaces back to tabs.                                                            

• Macintosh Line Endings (CR)  Convert line breaks according to Mac conventions.                      

• Unix Line Endings (LF)  Convert line breaks for UNIX and OS X.                                    

• Windows Line Endings (CR+LF)  Convert line breaks for Windows.                

• Smart Quotes  Convert straight quotes to curly quotes.                                                       

• Straight Quotes  Convert curly quotes to straight quotes.                                                  

• Rotate13  Garble and un-garble text using a very simple method.                                                                 

• Windows- to Mac-Encoding  Convert from Windows to Mac encoding.                        

• Mac- to Windows-Encoding  Convert from Mac to Windows encoding.                        
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Format 

• Reformat  A combination of Trim Lines, Remove Line Endings,                                                                 

Remove Multiple Spaces and Remove Quotes preserving 

paragraphs. 

• Remove Attachments  Removes attachments from rich text.                                     

• Remove Line Endings  Removes line endings.                                      

• Remove Links  Removes links from rich text.                                                       

• Remove Multiple Feeds  Removes multiple line feeds.                                 

• Remove Multiple Spaces  Replaces multiple spaces with a single space.                               

• Remove Quotes  Removes <quotes>.                                                  

• Shift Right  Indents text using tabs.                                                              

• Shift Left  Outdents text using tabs.                                                                  

• Sort Lines Ascending  Sorts lines alphabetically.                                       

• Sort Lines Descending  Sorts lines alphabetically, descending.                                    

• Trim Line Beginnings  Trims all white space from the beginning of lines.                                       

• Trim Line Endings  Trims all white space from the end of lines.                                              

• Trim Lines  Trims white space from beginning and end of lines.                                                               

Statistics 

Count characters, spaces, words, and lines. As this function does not modify the selected text, it 

is possible to use this also for read-only text like received email messages or HTML pages. 

Known bugs and limitations 

Do not use another WordService command while a results panel is displayed. 

Version history 

2.8.1 NEW Can be double-clicked and installed like an application.                              

 NEW Spanish localization by Ramón Navajas.                                          

 Improved Sorting of lines uses localized sorting rules.                                

 Improved Initial Caps of Sentences service.                                

 Improved Updated services names optimized for OS X Lion or later.                                

 Improved Appearance of alert dialogs.                                

 Improved New icon.                                

 Fixed Issue with removing multiple spaces or line feeds from rich text.                                          
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 Removed Obsolete text-to-speech services.                                 

 Required Intel-based Mac, OS X 10.6.8 or later.                                 

!
2.8 NEW Compatibility to Mac OS X 10.6 Snow Leopard.                                  

 Improved Optimized for Mac OS X 10.5 Leopard and 10.6 Snow Leopard.                                

 Fixed Rare date/time formatting issue.                                          

 Required Mac OS X 10.5 or later.                                 

2.7 NEW Reformatting of rich texts retains alignment.                                  

 NEW Universal binary for Intel- and PowerPC-based Macs.                                          

 Required Mac OS X 10.3.9 or later.                                 

2.6.1 Fixed Bug of Mail.app on Mac OS X 10.4 bypassed.                              

2.6 NEW Services > Format > Remove Attachments.                                  

 NEW Services > Format > Remove Multiple Feeds.                                          

 NEW Services > Format > Remove Links.                                          

  Reformat, Remove Multiple Spaces, Remove Quotes, All Caps, Low                                                     -

ercase, Initial Caps Of Words, Encode Tabs, and Decode Tabs sup-

port rich (‘styled’) text and retain formatting; Smart/Straight Quotes 

support rich text, too. 

 Improved Format > Reformat.                                

 Improved German localization.                                

 Improved Minor performance improvements.                                

 Required Mac OS X 10.3 or later.                                 

2.5.3 NEW Czech localization by Jan Cinert.                              

2.5.2 Improved Sorting is now case insensitive.                    

 Improved French localization.                                

2.5.1 Improved French, Italian and Dutch localizations.                    

 Improved Compiled using of GCC 3.3 and our latest classes; higher perfor                               -

mance. 

 Improved Description of how to fix the Carbon bug (no services at all under                                

some circumstances) added. 

2.5 NEW Insert > Short Date and Insert > Short Date & Time; Insert > Date                                  

and Insert > Date & Time renamed. 

 Improved Shortcuts of Shift Left/Right changed.                                

 NEW Shortcut Command-} added to Insert > Long Date.                                          

!
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2.4.2 Skipped                         

… 

1.0 Initial release.             

Contacting us 

Do you want to send us comments, bug reports or feature requests concerning WordService? 

Do you have any questions about our products, our technology or our company? Do you work 

for the press or are you an investor? Please do not hesitate and feel free to contact us at any 

time. 

License agreement 

PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS 

SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE 

AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE 

SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVON-

TECHNOLOGIES LLC. 

1. License. The application and other components (sound and graphics) accompanying this Li-

cense, whether on disk, in read only memory, or on any other media (the ‘Software’), and the 

related documentation are licensed to you by DEVONtechnologies. You own the disk on which 

the Software is recorded but DEVONtechnologies and/or DEVONtechnologies’ Licensor(s) re-

tain title to the Software and related documentation. This License allows you to non-simulta-

neously use the Software on multiple computers by the same person. 

2. The Software contains copyrighted material, trade secrets and other proprietary material 

and in order to protect them you may not decompile, reverse engineer, disassemble or other-

wise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, 

lease, or create derivative works based upon the Software in whole or in part. You may not dis-

tribute the Software in any form, including, but not limited to, electronic information service 

distribution, bulletin board distribution, and magnetic or optical medium distribution.  

3. Disclaimer of Warranty on Software. You expressly acknowledge and agree that use of the 

Software is at your sole risk. The Software and related documentation is provided ‘AS IS’ and 

without warranty of any kind. 
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4. Limitation of Liability. UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL 

DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL 

DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RE-

LATED DOCUMENTATION. In no event shall DEVONtechnologies’ total liability to you for all 

damages, losses and causes of action (whether in contract, tort (including negligence) or other-

wise) exceed the amount paid by you for the Software. 

Apple, Carbon, Classic, Cocoa, Colorsync, Darwin, Mac OS X, Quicktime, Quartz and all other 

registered names are trademarks of their respective owners.
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